import Foundation
let pattern = #"<abbr>(\S.*?)<\/abbr>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"content example <abbr variable-title="notepad 1">data <abbr variable-title="notepad 2">sample value </abbr>sample conten</abbr> <abbr variable-title="notepad 2">sample value </abbr>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span class='notranslate'>$1</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)