using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<abbr>(\S.*?)<\/abbr>";
string substitution = @"<span class='notranslate'>$1</span>";
string input = @"content example <abbr variable-title=""notepad 1"">data <abbr variable-title=""notepad 2"">sample value </abbr>sample conten</abbr> <abbr variable-title=""notepad 2"">sample value </abbr>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}