const regex = /<abbr>(\S.*?)<\/abbr>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<abbr>(\\S.*?)<\\\/abbr>', 'gi')
const str = `content example <abbr variable-title="notepad 1">data <abbr variable-title="notepad 2">sample value </abbr>sample conten</abbr> <abbr variable-title="notepad 2">sample value </abbr>`;
const subst = `<span class='notranslate'>$1</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);