re = /<abbr>(\S.*?)<\/abbr>/i
str = 'content example <abbr variable-title="notepad 1">data <abbr variable-title="notepad 2">sample value </abbr>sample conten</abbr> <abbr variable-title="notepad 2">sample value </abbr>'
subst = '<span class=\'notranslate\'>$1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result