import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<abbr>(\\S.*?)<\\/abbr>";
final String string = "content example <abbr variable-title=\"notepad 1\">data <abbr variable-title=\"notepad 2\">sample value </abbr>sample conten</abbr> <abbr variable-title=\"notepad 2\">sample value </abbr>";
final String subst = "<span class='notranslate'>$1</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}