# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<abbr>(\S.*?)<\\/abbr>/<span class='notranslate'>$1<\/span>/gi;t' <<< "content example <abbr variable-title=\"notepad 1\">data <abbr variable-title=\"notepad 2\">sample value </abbr>sample conten</abbr> <abbr variable-title=\"notepad 2\">sample value </abbr>"