// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<abbr>(\S.*?)<\/abbr>").unwrap();
let string = "content example <abbr variable-title=\"notepad 1\">data <abbr variable-title=\"notepad 2\">sample value </abbr>sample conten</abbr> <abbr variable-title=\"notepad 2\">sample value </abbr>";
let substitution = "<span class='notranslate'>$1</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}