# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<abbr>(\S.*?)<\/abbr>"
test_str = "content example <abbr variable-title=\"notepad 1\">data <abbr variable-title=\"notepad 2\">sample value </abbr>sample conten</abbr> <abbr variable-title=\"notepad 2\">sample value </abbr>"
subst = "<span class='notranslate'>$1</span>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.