import Foundation
let pattern = ##"^([\s\S]*?)\n#Guest(?:\n.*){3}"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
set wlan vap SSID enable
set wlan enable
#Guest Wireless (Password must be 8-64 characters)
add wlan vap ssid
set wlan vap security-type WPA/WPA2
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)