$re = '/^([\s\S]*?)\n#Guest(?:\n.*){3}/';
$str = 'set wlan vap SSID enable
set wlan enable
#Guest Wireless (Password must be 8-64 characters)
add wlan vap ssid
set wlan vap security-type WPA/WPA2
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;