# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([\s\S]*?)\n#Guest(?:\n.*){3}"
test_str = ("set wlan vap SSID enable\n"
"set wlan enable\n"
"#Guest Wireless (Password must be 8-64 characters)\n"
"add wlan vap ssid\n"
"set wlan vap security-type WPA/WPA2\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.