import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\s\\S]*?)\\n#Guest(?:\\n.*){3}";
final String string = "set wlan vap SSID enable\n"
+ "set wlan enable\n"
+ "#Guest Wireless (Password must be 8-64 characters)\n"
+ "add wlan vap ssid\n"
+ "set wlan vap security-type WPA/WPA2\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}