const regex = /^([\s\S]*?)\n#Guest(?:\n.*){3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\s\\S]*?)\\n#Guest(?:\\n.*){3}', 'g')
const str = `set wlan vap SSID enable
set wlan enable
#Guest Wireless (Password must be 8-64 characters)
add wlan vap ssid
set wlan vap security-type WPA/WPA2
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);