use strict;
my $str = 'set wlan vap SSID enable
set wlan enable
#Guest Wireless (Password must be 8-64 characters)
add wlan vap ssid
set wlan vap security-type WPA/WPA2
';
my $regex = qr/^([\s\S]*?)\n#Guest(?:\n.*){3}/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";