using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\s\S]*?)\n#Guest(?:\n.*){3}";
string substitution = @"$1";
string input = @"set wlan vap SSID enable
set wlan enable
#Guest Wireless (Password must be 8-64 characters)
add wlan vap ssid
set wlan vap security-type WPA/WPA2
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}