// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([\s\S]*?)\n#Guest(?:\n.*){3}").unwrap();
let string = "set wlan vap SSID enable
set wlan enable
#Guest Wireless (Password must be 8-64 characters)
add wlan vap ssid
set wlan vap security-type WPA/WPA2
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}