package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([\s\S]*?)\n#Guest(?:\n.*){3}`)
var str = `set wlan vap SSID enable
set wlan enable
#Guest Wireless (Password must be 8-64 characters)
add wlan vap ssid
set wlan vap security-type WPA/WPA2
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}