# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([\s\S]*?)\n#Guest(?:\n.*){3}/$1/g;t' <<< "set wlan vap SSID enable
set wlan enable
#Guest Wireless (Password must be 8-64 characters)
add wlan vap ssid
set wlan vap security-type WPA/WPA2
"