import Foundation
let pattern = #"\$_\.getObjectInstance\((?:\{([^;]*)\}|)\);"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
var pdr_manager = $_.UNINITIALIZED();
var internalWidgets = $_.getObjectInstance();
var categorySelect= $_.UNINITIALIZED();
var operatorMap = $_.getObjectInstance({
'EQUAL': '='
});
firstColumnCheckBox: $_.getObjectInstance({
isEnabled: true,
allowMultipleSelection: true,
field: {'Select':nah},
width: 65
}),
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{$1};"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)