use strict;
my $str = 'var pdr_manager = $_.UNINITIALIZED();
var internalWidgets = $_.getObjectInstance();
var categorySelect= $_.UNINITIALIZED();
var operatorMap = $_.getObjectInstance({
\'EQUAL\': \'=\'
});
firstColumnCheckBox: $_.getObjectInstance({
isEnabled: true,
allowMultipleSelection: true,
field: {\'Select\':nah},
width: 65
}),';
my $regex = qr/\$_\.getObjectInstance\((?:\{([^;]*)\}|)\);/p;
my $subst = '{$1};';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";