// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$_\.getObjectInstance\((?:\{([^;]*)\}|)\);").unwrap();
let string = "var pdr_manager = $_.UNINITIALIZED();
var internalWidgets = $_.getObjectInstance();
var categorySelect= $_.UNINITIALIZED();
var operatorMap = $_.getObjectInstance({
'EQUAL': '='
});
firstColumnCheckBox: $_.getObjectInstance({
isEnabled: true,
allowMultipleSelection: true,
field: {'Select':nah},
width: 65
}),";
let substitution = "{$1};";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}