# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\$_\.getObjectInstance\((?:\{([^;]*)\}|)\);"
test_str = ("var pdr_manager = $_.UNINITIALIZED();\n"
"var internalWidgets = $_.getObjectInstance();\n"
"var categorySelect= $_.UNINITIALIZED();\n\n\n"
"var operatorMap = $_.getObjectInstance({\n"
" 'EQUAL': '='\n"
"});\n\n\n"
" firstColumnCheckBox: $_.getObjectInstance({\n"
" isEnabled: true,\n"
" allowMultipleSelection: true,\n"
" field: {'Select':nah},\n"
" width: 65\n"
" }),")
subst = "{$1};"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.