using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$_\.getObjectInstance\((?:\{([^;]*)\}|)\);";
string substitution = @"{$1};";
string input = @"var pdr_manager = $_.UNINITIALIZED();
var internalWidgets = $_.getObjectInstance();
var categorySelect= $_.UNINITIALIZED();
var operatorMap = $_.getObjectInstance({
'EQUAL': '='
});
firstColumnCheckBox: $_.getObjectInstance({
isEnabled: true,
allowMultipleSelection: true,
field: {'Select':nah},
width: 65
}),";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}