import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$_\\.getObjectInstance\\((?:\\{([^;]*)\\}|)\\);";
final String string = "var pdr_manager = $_.UNINITIALIZED();\n"
+ "var internalWidgets = $_.getObjectInstance();\n"
+ "var categorySelect= $_.UNINITIALIZED();\n\n\n"
+ "var operatorMap = $_.getObjectInstance({\n"
+ " 'EQUAL': '='\n"
+ "});\n\n\n"
+ " firstColumnCheckBox: $_.getObjectInstance({\n"
+ " isEnabled: true,\n"
+ " allowMultipleSelection: true,\n"
+ " field: {'Select':nah},\n"
+ " width: 65\n"
+ " }),";
final String subst = "{$1};";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}