import Foundation
let pattern = #"(\d{2}\.\d{3})([A-Z]{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
00.000LB
12.345GM
XXXXXXXX
XX.XXXXX
00.000XX
1LB
1.0LB
1.00LB
01.00LB
01.000LB
001.00LB
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)