# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{2}\.\d{3})([A-Z]{2})"
test_str = ("00.000LB\n"
"12.345GM\n"
"XXXXXXXX\n"
"XX.XXXXX\n"
"00.000XX\n"
"1LB\n"
"1.0LB\n"
"1.00LB\n"
"01.00LB\n"
"01.000LB\n"
"001.00LB")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.