const regex = /(\d{2}\.\d{3})([A-Z]{2})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2}\\.\\d{3})([A-Z]{2})', 'g')
const str = `00.000LB
12.345GM
XXXXXXXX
XX.XXXXX
00.000XX
1LB
1.0LB
1.00LB
01.00LB
01.000LB
001.00LB`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}