re = /(\d{2}\.\d{3})([A-Z]{2})/
str = '00.000LB
12.345GM
XXXXXXXX
XX.XXXXX
00.000XX
1LB
1.0LB
1.00LB
01.00LB
01.000LB
001.00LB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end