using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{2}\.\d{3})([A-Z]{2})";
string input = @"00.000LB
12.345GM
XXXXXXXX
XX.XXXXX
00.000XX
1LB
1.0LB
1.00LB
01.00LB
01.000LB
001.00LB";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}