import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2}\\.\\d{3})([A-Z]{2})";
final String string = "00.000LB\n"
+ "12.345GM\n"
+ "XXXXXXXX\n"
+ "XX.XXXXX\n"
+ "00.000XX\n"
+ "1LB\n"
+ "1.0LB\n"
+ "1.00LB\n"
+ "01.00LB\n"
+ "01.000LB\n"
+ "001.00LB";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}