// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{2}\.\d{3})([A-Z]{2})").unwrap();
let string = "00.000LB
12.345GM
XXXXXXXX
XX.XXXXX
00.000XX
1LB
1.0LB
1.00LB
01.00LB
01.000LB
001.00LB";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}