package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{2}\.\d{3})([A-Z]{2})`)
var str = `00.000LB
12.345GM
XXXXXXXX
XX.XXXXX
00.000XX
1LB
1.0LB
1.00LB
01.00LB
01.000LB
001.00LB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}