#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{2}\.\d{3})([A-Z]{2})"
Local $sString = "00.000LB" & @CRLF & _
"12.345GM" & @CRLF & _
"XXXXXXXX" & @CRLF & _
"XX.XXXXX" & @CRLF & _
"00.000XX" & @CRLF & _
"1LB" & @CRLF & _
"1.0LB" & @CRLF & _
"1.00LB" & @CRLF & _
"01.00LB" & @CRLF & _
"01.000LB" & @CRLF & _
"001.00LB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")