// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<\?php echo L10n\:\:icon\(')(.*?)('\); \?>)(\n)(\s+)(<\?php echo UI\:\:timeago)(.*?)(\); \?\>)").unwrap();
let string = "<?php echo L10n::icon('calendar'); ?>
<?php echo UI::timeago($License->iso_8601_purchased, $License->purchased); ?>";
let substitution = "$6$7, '$2'$8";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}