re = /(<\?php echo L10n\:\:icon\(')(.*?)('\); \?>)(\n)(\s+)(<\?php echo UI\:\:timeago)(.*?)(\); \?\>)/m
str = '<?php echo L10n::icon(\'calendar\'); ?>
<?php echo UI::timeago($License->iso_8601_purchased, $License->purchased); ?>'
subst = '$6$7, \'$2\'$8'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result