use strict;
my $str = '<?php echo L10n::icon(\'calendar\'); ?>
<?php echo UI::timeago($License->iso_8601_purchased, $License->purchased); ?>';
my $regex = qr/(<\?php echo L10n\:\:icon\(')(.*?)('\); \?>)(\n)(\s+)(<\?php echo UI\:\:timeago)(.*?)(\); \?\>)/mp;
my $subst = '$6$7, \'$2\'$8';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";