import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\?php echo L10n\\:\\:icon\\(')(.*?)('\\); \\?>)(\\n)(\\s+)(<\\?php echo UI\\:\\:timeago)(.*?)(\\); \\?\\>)";
final String string = "<?php echo L10n::icon('calendar'); ?>\n"
+ " <?php echo UI::timeago($License->iso_8601_purchased, $License->purchased); ?>";
final String subst = "$6$7, '$2'$8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}