using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\?php echo L10n\:\:icon\(')(.*?)('\); \?>)(\n)(\s+)(<\?php echo UI\:\:timeago)(.*?)(\); \?\>)";
string substitution = @"$6$7, '$2'$8";
string input = @"<?php echo L10n::icon('calendar'); ?>
<?php echo UI::timeago($License->iso_8601_purchased, $License->purchased); ?>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}