import Foundation
let pattern = #"\>\s*\{\{|\>\s*[a-zA-Z0-9]|\:\s*[\'|\"]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
HTML plain strings
<a>zxc
<a> zxc
<a> 7xc
<a>
zxc
<a>
zxc
<a>
7xc
HTML strings evaluated by angular
<a>{{ 'asdasd
<a>{{'asdasd
<a> {{ 'asdasd
<a> {{'asdasd
<a>{{ "asdasd
<a>{{"asdasd
<a> {{ "asdasd
<a> {{"asdasd
<a>
{{ 'asdasd
<a>
{{'asdasd
<a>
{{ 'asdasd
<a>
{{'asdasd
<a>
{{ "asdasd
<a>
{{"asdasd
<a>
{{ "asdasd
<a>
{{"asdasd
JS plain strings
asd: '
asd:'
asd: "
asd:"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}