const regex = /\>\s*\{\{|\>\s*[a-zA-Z0-9]|\:\s*[\'|\"]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\>\\s*\\{\\{|\\>\\s*[a-zA-Z0-9]|\\:\\s*[\\\'|\\"]', '')
const str = `HTML plain strings
<a>zxc
<a> zxc
<a> 7xc
<a>
zxc
<a>
zxc
<a>
7xc
HTML strings evaluated by angular
<a>{{ 'asdasd
<a>{{'asdasd
<a> {{ 'asdasd
<a> {{'asdasd
<a>{{ "asdasd
<a>{{"asdasd
<a> {{ "asdasd
<a> {{"asdasd
<a>
{{ 'asdasd
<a>
{{'asdasd
<a>
{{ 'asdasd
<a>
{{'asdasd
<a>
{{ "asdasd
<a>
{{"asdasd
<a>
{{ "asdasd
<a>
{{"asdasd
JS plain strings
asd: '
asd:'
asd: "
asd:"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}