// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\>\s*\{\{|\>\s*[a-zA-Z0-9]|\:\s*[\'|\"]"#).unwrap();
let string = "HTML plain strings
<a>zxc
<a> zxc
<a> 7xc
<a>
zxc
<a>
zxc
<a>
7xc
HTML strings evaluated by angular
<a>{{ 'asdasd
<a>{{'asdasd
<a> {{ 'asdasd
<a> {{'asdasd
<a>{{ \"asdasd
<a>{{\"asdasd
<a> {{ \"asdasd
<a> {{\"asdasd
<a>
{{ 'asdasd
<a>
{{'asdasd
<a>
{{ 'asdasd
<a>
{{'asdasd
<a>
{{ \"asdasd
<a>
{{\"asdasd
<a>
{{ \"asdasd
<a>
{{\"asdasd
JS plain strings
asd: '
asd:'
asd: \"
asd:\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}