package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\>\s*\{\{|\>\s*[a-zA-Z0-9]|\:\s*[\'|\"]`)
var str = `HTML plain strings
<a>zxc
<a> zxc
<a> 7xc
<a>
zxc
<a>
zxc
<a>
7xc
HTML strings evaluated by angular
<a>{{ 'asdasd
<a>{{'asdasd
<a> {{ 'asdasd
<a> {{'asdasd
<a>{{ "asdasd
<a>{{"asdasd
<a> {{ "asdasd
<a> {{"asdasd
<a>
{{ 'asdasd
<a>
{{'asdasd
<a>
{{ 'asdasd
<a>
{{'asdasd
<a>
{{ "asdasd
<a>
{{"asdasd
<a>
{{ "asdasd
<a>
{{"asdasd
JS plain strings
asd: '
asd:'
asd: "
asd:"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}