# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\>\s*\{\{|\>\s*[a-zA-Z0-9]|\:\s*[\'|\"]"
test_str = ("HTML plain strings\n"
"<a>zxc\n"
"<a> zxc\n"
"<a> 7xc\n\n\n"
"<a>\n"
" zxc\n\n"
"<a>\n"
" zxc\n\n"
"<a>\n"
" 7xc\n\n\n"
"HTML strings evaluated by angular\n"
"<a>{{ 'asdasd\n"
"<a>{{'asdasd\n"
"<a> {{ 'asdasd\n"
"<a> {{'asdasd\n"
"<a>{{ \"asdasd\n"
"<a>{{\"asdasd\n"
"<a> {{ \"asdasd\n"
"<a> {{\"asdasd\n\n"
"<a>\n"
" {{ 'asdasd\n"
"<a>\n"
" {{'asdasd\n"
"<a>\n"
" {{ 'asdasd\n"
"<a>\n"
" {{'asdasd\n"
"<a>\n"
" {{ \"asdasd\n"
"<a>\n"
" {{\"asdasd\n"
"<a>\n"
" {{ \"asdasd\n"
"<a>\n"
" {{\"asdasd\n\n\n"
"JS plain strings\n"
"asd: '\n"
"asd:'\n"
"asd: \"\n"
"asd:\"")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.