re = /\>\s*\{\{|\>\s*[a-zA-Z0-9]|\:\s*[\'|\"]/
str = 'HTML plain strings
<a>zxc
<a> zxc
<a> 7xc
<a>
zxc
<a>
zxc
<a>
7xc
HTML strings evaluated by angular
<a>{{ \'asdasd
<a>{{\'asdasd
<a> {{ \'asdasd
<a> {{\'asdasd
<a>{{ "asdasd
<a>{{"asdasd
<a> {{ "asdasd
<a> {{"asdasd
<a>
{{ \'asdasd
<a>
{{\'asdasd
<a>
{{ \'asdasd
<a>
{{\'asdasd
<a>
{{ "asdasd
<a>
{{"asdasd
<a>
{{ "asdasd
<a>
{{"asdasd
JS plain strings
asd: \'
asd:\'
asd: "
asd:"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end