use strict;
my $str = 'HTML plain strings
<a>zxc
<a> zxc
<a> 7xc
<a>
zxc
<a>
zxc
<a>
7xc
HTML strings evaluated by angular
<a>{{ \'asdasd
<a>{{\'asdasd
<a> {{ \'asdasd
<a> {{\'asdasd
<a>{{ "asdasd
<a>{{"asdasd
<a> {{ "asdasd
<a> {{"asdasd
<a>
{{ \'asdasd
<a>
{{\'asdasd
<a>
{{ \'asdasd
<a>
{{\'asdasd
<a>
{{ "asdasd
<a>
{{"asdasd
<a>
{{ "asdasd
<a>
{{"asdasd
JS plain strings
asd: \'
asd:\'
asd: "
asd:"';
my $regex = qr/\>\s*\{\{|\>\s*[a-zA-Z0-9]|\:\s*[\'|\"]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}