$re = '/\>\s*\{\{|\>\s*[a-zA-Z0-9]|\:\s*[\'|\"]/';
$str = 'HTML plain strings
<a>zxc
<a> zxc
<a> 7xc
<a>
zxc
<a>
zxc
<a>
7xc
HTML strings evaluated by angular
<a>{{ \'asdasd
<a>{{\'asdasd
<a> {{ \'asdasd
<a> {{\'asdasd
<a>{{ "asdasd
<a>{{"asdasd
<a> {{ "asdasd
<a> {{"asdasd
<a>
{{ \'asdasd
<a>
{{\'asdasd
<a>
{{ \'asdasd
<a>
{{\'asdasd
<a>
{{ "asdasd
<a>
{{"asdasd
<a>
{{ "asdasd
<a>
{{"asdasd
JS plain strings
asd: \'
asd:\'
asd: "
asd:"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);