#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\>\s*\{\{|\>\s*[a-zA-Z0-9]|\:\s*[\'|\"]"
Local $sString = "HTML plain strings" & @CRLF & _
"<a>zxc" & @CRLF & _
"<a> zxc" & @CRLF & _
"<a> 7xc" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<a>" & @CRLF & _
" zxc" & @CRLF & _
"" & @CRLF & _
"<a>" & @CRLF & _
" zxc" & @CRLF & _
"" & @CRLF & _
"<a>" & @CRLF & _
" 7xc" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"HTML strings evaluated by angular" & @CRLF & _
"<a>{{ 'asdasd" & @CRLF & _
"<a>{{'asdasd" & @CRLF & _
"<a> {{ 'asdasd" & @CRLF & _
"<a> {{'asdasd" & @CRLF & _
"<a>{{ "asdasd" & @CRLF & _
"<a>{{"asdasd" & @CRLF & _
"<a> {{ "asdasd" & @CRLF & _
"<a> {{"asdasd" & @CRLF & _
"" & @CRLF & _
"<a>" & @CRLF & _
" {{ 'asdasd" & @CRLF & _
"<a>" & @CRLF & _
" {{'asdasd" & @CRLF & _
"<a>" & @CRLF & _
" {{ 'asdasd" & @CRLF & _
"<a>" & @CRLF & _
" {{'asdasd" & @CRLF & _
"<a>" & @CRLF & _
" {{ "asdasd" & @CRLF & _
"<a>" & @CRLF & _
" {{"asdasd" & @CRLF & _
"<a>" & @CRLF & _
" {{ "asdasd" & @CRLF & _
"<a>" & @CRLF & _
" {{"asdasd" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"JS plain strings" & @CRLF & _
"asd: '" & @CRLF & _
"asd:'" & @CRLF & _
"asd: "" & @CRLF & _
"asd:""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")