import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\>\\s*\\{\\{|\\>\\s*[a-zA-Z0-9]|\\:\\s*[\\'|\\\"]";
final String string = "HTML plain strings\n"
+ "<a>zxc\n"
+ "<a> zxc\n"
+ "<a> 7xc\n\n\n"
+ "<a>\n"
+ " zxc\n\n"
+ "<a>\n"
+ " zxc\n\n"
+ "<a>\n"
+ " 7xc\n\n\n"
+ "HTML strings evaluated by angular\n"
+ "<a>{{ 'asdasd\n"
+ "<a>{{'asdasd\n"
+ "<a> {{ 'asdasd\n"
+ "<a> {{'asdasd\n"
+ "<a>{{ \"asdasd\n"
+ "<a>{{\"asdasd\n"
+ "<a> {{ \"asdasd\n"
+ "<a> {{\"asdasd\n\n"
+ "<a>\n"
+ " {{ 'asdasd\n"
+ "<a>\n"
+ " {{'asdasd\n"
+ "<a>\n"
+ " {{ 'asdasd\n"
+ "<a>\n"
+ " {{'asdasd\n"
+ "<a>\n"
+ " {{ \"asdasd\n"
+ "<a>\n"
+ " {{\"asdasd\n"
+ "<a>\n"
+ " {{ \"asdasd\n"
+ "<a>\n"
+ " {{\"asdasd\n\n\n"
+ "JS plain strings\n"
+ "asd: '\n"
+ "asd:'\n"
+ "asd: \"\n"
+ "asd:\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}