import Foundation
let pattern = #"\s{2,}|\(R\)|\(TM\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)