// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s{2,}|\(R\)|\(TM\)").unwrap();
let string = "Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}